Can't set up - Sample Blog with API-based CMS in ReactJS

Hello, I am trying to test out and use prismic. I follow the instructions to set up the project in my terminal. The project I am following is https://intercom.help/prismicio/en/articles/2685559-sample-blog-with-api-based-cms-in-reactjs , however when I get to step 2: enter prismic theme --theme-url https://github.com/prismicio/reactjs-blog --conf src/prismic-configuration.js to set up files/ local files, nothing sets up and I get an error message in my terminal: ? Password: [hidden] This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). The promise rejected with the reason: SyntaxError: Unexpected token o in JSON at position 1 at JSON.parse (<anonymous>) at /usr/local/lib/node_modules/prismic-cli/bin/commands/signup.js:68:36 at processTicksAndRejections (internal/process/task_queues.js:94:5) I have no idea what this means. The documentations is very unclear, and not written well.... so I am not sure to get CLI to work and start this project.

Hello @ainneo, welcome to the Community !

I'm sorry to hear you're having problems using this tutorial and thank you for the feedback, I'll make sure to add a note in the backlog so we can update this documentation to make it more clear.

Could you please try installing this version of the prismic-cli:

npm install -g prismic-cli@3.8.3-beta.0

And then re try the command that the guide gives you:

prismic theme --theme-url https://github.com/prismicio/reactjs-blog --conf src/prismic-configuration.js

Also, if you run the command and it doesn’t create a repository. Please run prismic login to login again in your console and then re run the command.

Let me know if this works for you

I am sorry, but you guys need to rewrite your documentation... it doesn't make any sense...

Hey, I'm sorry to hear that you're having a difficult time testing Prismic. Did you found the last instructions to be unclear or didn't help you solve the original error? We can try and fix this, I'll just need to know exactly where you're getting stuck so we can move further.

Looking forward to your comments

This issue has been closed due to inactivity. Flag to reopen.