Issues with gatsby-source-prismic-graphql

Hey Prismic Community,

I’ve just installed a new Gatsby site and as soon as I am adding the gatsby-source-prismic-graphql plugin and when I run gatsby develop it breaks / does not run.

This is my console error:

Error in "/Users/xxx/Sites/xxx/node_modules/gatsby-source-prismic-graphql/gatsby-node.js": No valid exports main found for '/Users/xxx/Sites/xxx/node_modules/extract-files'

This is something I’ve never run into before, while it’s only my second time using the official graphql plugin.

  • To install I ran npm install --save gatsby-source-prismic-graphql prismic-reactjs
  • I’ve added my repo name correctly
  • I’ve added my API key correctly

I am sure I am missing something extremely basic here, but can’t find out, tried to set up a new project three times, always ending up the same.

Any ideas? Thank you.

Edit: I currently have only two pages (/ and reel) so I don’t have a linkResolver and pages setup inside my config files.

Ok, just span up an older project I had and updated the prismic repo credentials and now it works totally fine.

Gatsby version of “old” project is 2.19.45 (new gatsby install is 2.21.37)
Prismic source plugin version is 3.5.0 (don’t know current / last version).

Is it still me or is this an issue?

Closed due to inactivity.

If you are planning to create a new Gatsby project, then we recommend you to read this blog post first.