Links only showing web and not documents as option in dropdown admin

I have selected a link field to choose documents in admin but for some reasen i only see link to web as an option in the dropdown menu. What can have happened? Link used to work or do i have to use content relationship to get url of pages.

"nuxt-sm": "^0.0.8",
"slice-machine-ui": "^0.1.0-beta.2",

Hi Victor,

This was the behaviour on the version of Slice Machine UI that you have installed. In the latest stable version, it includes all the correct links. You can get this version and all the links by running the following command:

npm i slice-machine-ui@latest


Thank! :smiley:

I updated but I still got the same error, only possible to web.
Do I need to do something else? Like rebuild the whole slice? I tried to remove the link and add a new with new name but still the same.

Any clues?
Thank you so much

Yes, once you update you will need to re-add this field and push the Slice to Prismic. Can you confirm slice-machine-ui is now on 0.1.0?


Yes I can confirm. I changed to "0.1.0-alpha.13" and it worked. I got the problem with
import { getStoriesPaths } from 'slice-machine-ui/helpers/storybook' where is looks for .slicemachine in the wrong folder trying 0.1.0. Do you know when this will be fixed?

Thanks Phil!

If you're talking about the issue described here:

Hugo has contacted storybook for help with that and so until we get a response there you will have to define the paths yourself in the nuxt.config.

thanks Phil

Hi! I'm currently on slice-machine-ui 0.1.2 and have the same problem with links only being possible for weblinks. Any suggestions?

Hi Hannah,

Sorry this thread never got updated, but this has been discussed here:

This is available from Slice Machine v 0.2.0.


1 Like