The uid field seems to auto fill based on the most recently updated text field

OK, that strange. Are you adding content in the other fields first, like a rich text? because the UID will fill from any text field where content is added first?

No, I’m adding the Title (which updates the UID), then every time I enter anything in the other text fields it will update the UID as well.

Can you send me your repo id in a private message so I can look in to this further?

Hey Diz,

I made a clone of your repo to test this and it seems to work as expected for me. You can see my test here.

Hi Phil,

Sorry, I’ve just seen this. Looking at the video above, you aren’t entering the “Short Summary” field. If I enter in the title the UID gets updated (correctly). But, if you enter a short summary the UID gets updated, which isn’t want we want to happen.

Hey,

I’m still not seeing the behaviour you’re describing.

Can you send me a screen recording of what you’re describing?

Thanks.

Hi Phil,

Please can you do the following steps on your cloned repo?

  1. Enter a Title .
  2. Enter a Short Summary.
  3. Check if the UID has updated with the short summary value.

I will send over a screen recording later on today, when I have shorted out a tool for it.

Thanks

Hey Diz,

I’ve done this is the previous video I just sent you, you’ll need to click play to see the full thing.

You can use gify capture or loom.

Okay I can see that now.

1 Like

Thank you for sending this. OK, this is very clear now and not how it’s behaving in the clone which is strange.

Now I can see this I’m going to inform the dev team so they can investigate what’s going on here :slight_smile:

Ok thanks.

Is this likely to be looked at before Tuesday (15th September)? As the sit will be going live and this is something that we need to get fixed as all of the Article URL’s are currently wrong.

I really can’t say whether it will be fixed by then I’ll have to see what the dev team say, but I wouldn’t think so.

You can update the UID manually for the moment as a work around.

Ok, we will carry on manually editing it for now then.

Thanks.

1 Like

Hey Diz,

So I created an issue with the Dev team about this and hopefully at some they can find time to work on this. Whenever they have any update about if/when they will work on this I'll update you here.

Though as Levi pointed out:

Work around

  1. Add the content directly in the UID field and it won't change.

Alternatively
There may be a couple of steps that can lock your UID in place so that it's not overwritten:

  1. Add content to the field you wish to auto-populate the UID
  2. Either (click save) OR (go to the UID field and add then remove a space)

Hopefully this small process can help your case for the time being.

Let me know if it works.

Thank you. We will try those steps for now then.

This is being tracked as an open feature request.

If you have another use-case for this feature, you can 'Flag' this topic to reopen. Please use the :heart: button to show your support for the feature and check out our Feature Request Guidelines.