Toolbar Preview cookie issue

Hi,

Our site has been up for for more than a year now and the Preview suddenly stopped working. It display the preview but the preview does not include any new/unpublished content. It is only showing the currently published version of the page, not the latest saved version.
I check the io.prismic.preview cookie and it looks like this: {%22_tracker%22:%22Hxv7EtTo%22}
This doesn't look right. It is suppose to look like some sort of url correct ? Is this the actual problem ? If yes, how do I resolve this ? Please advise. Thanks.

4 Likes

Hi,

we have the same issue since a few days. Nothing changed on our side.

I don't know if this link is still up to date but this troubleshooting guide doesn't help : Troubleshooting: Previews

We also have the {%22_tracker%22:%22z9Ng7jyV%22} value for io.prismic.preview Cookie. Deleting it doesn't change a thing.

Can anyone from Prismic team can help us ?

I'm experiencing the same issue in our PHP project. Looking forward to some resolution.

Hi there,

We are investigating this issue and we will come back to you ASAP

I will create an issue in our issue tracking regarding this.

May I have your repositories names as well as a link to a broken preview if possible. (in a private message if necessary) to add it to the created issue.

Also, I have checked with our dev team, and they said that " {%22_tracker%22:%22z9Ng7jyV%22} value for io.prismic.preview is a normal cookie while not in preview.

the tracker is used for the toolbar, to display the documents of the current page.

Previews that works seems to got that kind of value:

{"_tracker":"<id>","<repo_name>.prismic.io":{"preview":"https://<repo_name>.prismic.io/previews/<id>:<id>?websitePreviewId=<id>"}}

Same issue here in Node/Javascript. Nothing changed on our side and preview stopped working.

We do a match in nginx to load the preview mode relying on the cookie name ~io.prismic.preview. Did that cookie change?

I think I am having the same issue. Previews were working last week and today I noticed that they aren't any more. Not sure what I've changed, and I've tried rolling back to a previous version but still get the same results.

After clicking the preview button in Prismic, I get stuck on the /preview route without getting redirected. No console errors. Following the debugging advice in this article, I checked the preview cookie, but the value isn't a URL like the article says it should be, so I am guessing this is causing/contributing to the issue. I'm not sure what's causing this though or how to resolve it (if this is even the issue). @angeloashmore any ideas?

Versions:

"gatsby-plugin-prismic-previews": "4.0.1",
"gatsby-source-prismic": "4.0.1",

Hi Sean,

It seems this isn't specific to Gatsby. @Fares is investigating with the team.

Hi there,

I have problem to getting the preview to work with new repositories. Our solution is that we have multiple repositories, one for each customer and the code base is the same for everyone. We get the repository name and etc from a config file so each customer has their own. I just noticed that the preview function does not seem to work on newly created repositores, the strange thing is that it works on older repositories.

The cookie io.prismic.preview that being set on the newer repositories only contain {"_tracker":"trackerId"} but on the older the cookie is {"_tracker":"trackerId","repo-name":{"preview":"repo-name/previews/id?websitePreviewId=previewId"}}

Anyone knows how to solve this?

//André

Hi @a.ekani
Thanks for reaching out, can you please share with us your repository name (in a private message if possible)

Hi community,

I am facing issues with the prismic preview. Until yesterday everything worked fine with the preview, but now the preview toolbar receives only 504 responses from the service and the preview does not work.

Can anybody help? Code is the same as yesterday when it worked. Maybe there is something wrong with my API-Settings or the preview settings of the repo? Or is it simply a bug in the service?

Happy for every hint and response.

Kind regards,
Ben

1 Like

Hey Benjamin,

We're tracking this issue here.

2 Likes

Hi. Responding about the preview issue, here's one of our repositories as a reference: https://stronger.prismic.io/

Hi there,

I am facing the same issue. Our repository is https://pageport-playground.prismic.io/

Looking forward . . . thanks!

1 Like

Here are some insights what I see in the browser. Maybe it helps:

This is in Chrome:

This is in Firefox:

Prismic toolbar is also empty in Chrome and Firefox:

Screenshot 2021-08-20 at 11.25.00

1 Like

Hi Fares,

Sure, here's the screenshot of my cookies on local and production site, with io.prismic.preview highlight:


Hope that helps. I'll be following the issue via the link you're sharing too.

Let me know if you need any else info. Thanks!

1 Like

Adding some additional context here for reference.

  1. I recently created a new repo and used the same stack to reference prismic as my older repos, the new repo works as expected for previewing content. So, this preview issue only seems to occur on older repos, possibly the ones that were migrated from the previous version of the toolbar.

  2. When inspecting the cookies between the two repos/sites, I'm not seeing "io.prismic.previewSession" in the older repo which the preview functionality is not working.

1 Like