Cannot get the Essential Slices to function in new project

Followed tutorial, and got Dependency conflicts with Theme -UI trying to install essential slices

npm Version: 7.7.6
node: 15.14
prismic: 3.8.14 & lastest alpha (tried both)

Hello Ryan,

Thanks for posting this question to us.

I am sorry but I don't understand your question completely. Could you please elaborate more, like

  1. The link of documentation that you are following?
  2. Screenshot of the error?

Thanks,
Priyanka

I follow the tutorial for nextjs setup with storybook and get dependency conflicts when installing your Essential Slices package.

Hello @hayes.ryan83

Are you trying to install Prismic's essential slices? If so, you need to run $ prismic sm --setup. It will set up a Next.js project with SliceMachine. Find complete detail in this article.

Thanks,
Priyanka

Yes, Im trying to install it. I alreadly ran the prismic sm --setup.

I've attempted the tutorial multiple times with different versions. I get the error listed above

If you follow the tutorial using the sample project install

Essential Slices will not work.

I tried using the setup manually and it seemed to install

Hello @hayes.ryan83

I am going to check this out and will come back to you.

Thanks,
Priyanka

Hello @hayes.ryan83

I have tested this out, and It seems essential slices are broken in the Example projects. I have submitted this issue with my dev team and will return to you when I hear back from them.

Thanks,
Priyanka