Can't open the constraint dropdowns of the relationship field

I'm trying to add constraints to my relationship field, but the dropdown elements (Constraint to custom type and Constraint to tags) can't be opened open, clicking on them does nothing. And this is the related error from the console:

main.js:461 Uncaught TypeError: this.state is not iterable
    at Object.settings#maskbuilder#masks (main.js:461)
    at main.js:310
    at Array.forEach (<anonymous>)
    at HTMLBodyElement.i (main.js:310)
    at HTMLBodyElement.<anonymous> (main.js:310)
    at HTMLBodyElement.dispatch (jquery-2.1.0.min.js:3)
    at HTMLBodyElement.$event.dispatch (drag-tools-2.2x.js:378)
    at HTMLBodyElement.r.handle (jquery-2.1.0.min.js:3)

Hi IIyas,

Welcome to the community!

I'll be happy to help debug this with you. Can you share with me the your repository URL and the name of the custom type where you are seeing this error?


I was able to recreate this issue. I'm passing this to issue to the dev team and hopefully someone can have a look at this soon. I would imagine it will be at least next week before we can work on this. Hopefully this isn't too much of a blocker in the mean time.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Just an update for everyone. A fix was worked on for this week and is scheduled to be tested next week.


Hi @Phil ,

any update on the release? Currently this not only blocks changing the constraint but also prevents documents from publishing..

i got the same bug, this is quite critical and it's a shame that no fix has been deployed yet.

Hi Everyone,

The fix for this has been reviewed and tested and should be released this week. Once it's out we'll update you here.


Is there any update on this? This is pretty critical in our move to prismic and is holding us up quite a bit

Hi Rob,

Welcome to the community!

This fix will be released in the next few days. I'll talk with the team to find out exactly when.

Is the recommended workaround to remove all constraints if you need to add new constraints?

Hi again everyone,

So I had an update from the team. This was a due to be released last week as you know, but during the process another bug was discovered and this had to be moved back and reworked. The team is working hard on this, but there won't be a fix released this week.

Fortunately though there is a workaround! In the custom type builder, select the 'JSON Editor' tab, find your content relationship and add your constraint here with the "customtypes" : [ "" ], option. You can see below I've added a constraint to my author custom type.

    "author_link" : {
      "type" : "Link",
      "config" : {
        "select" : "document",
        "customtypes" : [ "author" ],
        "label" : "Author Link"

Hopefully this workaround should help you all advance with your projects for the moment. In the meantime we'll keep working on this and we are again sorry for any inconvenience this is causing you.


Thanks for the solution. We could have got this solution 3 weeks earlier ;). I found that publish does not work well with adblocker because of the newly added sentry I guess. Please check this as this was not the issue last month

Yeah, that was my bad. I made the assumption this would be resolved sooner. My apologies. For the second issue can you create a new thread and share with us a screen recording of the and/or any errors you're getting in the console?

Just hit this too; would love to have this solved!

Experienced the same error too, just now. I used the JSON editor workaround which seems to work.

Can someone fix this please?

The fix is currently being worked on. In the meantime, please try the workaround.

We'll update everyone here once this is done.


During editing content relationship, the constraints are not working.

Reproduce Steps:

  1. Find a Custom Type, and click into it
  2. Add a content relationship field
  3. Add constraint to custom type or add constraint to tags
  4. Nothing happens. Meanwhile the following errors in console
    main.js:494 Uncaught TypeError: this.state is not iterable
    at Object.settings#maskbuilder#masks (main.js:494)
    at main.js:305
    at Array.forEach ()
    at HTMLBodyElement.i (main.js:305)
    at HTMLBodyElement. (main.js:305)
    at HTMLBodyElement.dispatch (jquery-2.1.0.min.js:3)
    at HTMLBodyElement.$event.dispatch (drag-tools-2.2x.js:378)
    at HTMLBodyElement.r.handle (jquery-2.1.0.min.js:3)
    (anonymous) @ main.js:494
    (anonymous) @ main.js:305
    i @ main.js:305
    (anonymous) @ main.js:305
    dispatch @ jquery-2.1.0.min.js:3
    event.dispatch @ drag-tools-2.2x.js:378 r.handle @ jquery-2.1.0.min.js:3 main.js:494 Uncaught TypeError: this.state is not iterable at onClickOpen (main.js:494) at s.default.createElement.onClick (main.js:329) at Object.s (main.js:437) at p (main.js:437) at main.js:437 at v (main.js:437) at at (main.js:437) at it (main.js:437) at st (main.js:437) at pt (main.js:437) at j (main.js:437) at (main.js:437)
    at Zt (main.js:437)
    at Xt (main.js:437)
    at t.unstable_runWithPriority (main.js:445)
    at Gi (main.js:437)
    at D (main.js:437)
    at Kt (main.js:437)

1 Like