Expected hoisted manifest for \“@prismicio/gatsby-source-prismic-graphql#gatsby#terser-webpack-plugin#schema-utils\”

I am hosting my site on Netlify but when the code builds I am getting an error. When I build locally with gatsby build all is good.

The error I am getting on Netlify is:

An unexpected error occurred: "expected hoisted manifest for "@prismicio/gatsby-source-prismic-graphql#gatsby#terser-webpack-plugin#schema-utils\

My packages.json is as follows:

{

"name": "gatsby-starter-default",
"private": true,
"description": "A simple starter to get up and developing quickly with Gatsby",
"version": "0.1.0",
"author": "Kyle Mathews mathews.kyle@gmail.com",
"dependencies": {
"@prismicio/gatsby-source-prismic-graphql": "^3.6.13",
"bulma": "^0.9.0",
"gatsby": "2.24.51",
"gatsby-image": "^2.4.8",
"gatsby-plugin-load-script": "^1.1.0",
"gatsby-plugin-manifest": "^2.4.13",
"gatsby-plugin-netlify": "^2.3.7",
"gatsby-plugin-offline": "^3.2.12",
"gatsby-plugin-react-helmet": "^3.3.5",
"gatsby-plugin-sass": "^2.3.6",
"gatsby-plugin-sharp": "^2.6.13",
"gatsby-source-filesystem": "^2.3.13",
"gatsby-transformer-sharp": "^2.5.6",
"node-sass": "^4.14.1",
"nuka-carousel": "^4.7.0",
"prismic-reactjs": "^1.3.1",
"prop-types": "^15.7.2",
"react": "^16.12.0",
"react-dom": "^16.12.0",
"react-helmet": "^6.1.0",
"react-icons": "^3.10.0",
"react-typography": "^0.16.19"
},
"devDependencies": {
"prettier": "2.0.5"
},
"keywords": [
"gatsby"
],
"license": "MIT",
"scripts": {
"build": "gatsby build",
"develop": "gatsby develop",
"format": "prettier --write "**/*.{js,jsx,ts,tsx,json,md}"",
"start": "npm run develop",
"serve": "gatsby serve",
"clean": "gatsby clean",
"test": "echo "Write tests! -> https://gatsby.dev/unit-testing" && exit 1",
"postinstall": "node scripts/injectPrismic.js"
},
"repository": {
"type": "git",
"url": "https://github.com/gatsbyjs/gatsby-starter-default"
},
"bugs": {
"url": "https://github.com/gatsbyjs/gatsby/issues"
}
}

Everything was working fine...

Try this - does it help?

1 Like

Delting the yarn.lock file and adding "gatsby-source-prismic-graphql": "npm:@prismicio/gatsby-source-prismic-graphql@^3.6.13" under dependencies got it working.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.