Fetching Data Issue (Custom Types Updating/Changing)

Hello Prismic Community,

I have an issue with fetching/updating data on my Custom Types. I'm using NextJS. I updated some of my custom types(added new fields, etc.) and I can't fetch the data (with client.getSingle -> page.data.field_name). It always returns 'undefined', although the field I'm trying get access to is visible in console.log. I've published/unpublished the Custom Types multiple times, removed the fields and then added them again, tried to change the name and so on - the same result each time.

My slicemachine version is up to date and it gives me no errors when syncing up my custom types. Same with the document editor - saves and publishes successfully.

Strangely enough, if I change my access token it returns the expected results(field name + the data) and everything starts to work just fine, but when I change the custom type again - I'm going into the same issue.

The data is displayed correctly in the API browser of my repo.

Could you please help me with that?

Hello @thereisnospoon27017

Welcome to the Prismic, and thanks for reaching out to us.

To debug it, I need minimal reproduction. Can you provide the query example, consoel.log print, and code files?

I am looking forward to hearing back from you.