Gatsby Cloud build error

Started around 2PM PST today (Apr 5) Gatsby build started to have following error while running site build using Gatsby Cloud:

"gatsby-source-prismic" threw an error while running the createSchemaCustomization lifecycle:
request to https://customtypes.prismic.io/slices failed, reason: connect ETIMEDOUT 108.159.227.79:443
For more details see How to File an Issue | Gatsby

The build was running fine at least until 10AM PST today (Apr 5) and all the sudden started to have this error.

There was no build/Env var change between those time and it's fine on my local environment, so I'm assuming it's something to do with Gatsby Cloud build, but thought posting here to see if anyone else is having same issue.

Here's list of gatsby related plugins I'm using
"gatsby": "^4.3.0",
"gatsby-plugin-brotli": "^2.1.0",
"gatsby-plugin-canonical-urls": "^4.3.0",
"gatsby-plugin-feed": "^4.3.0",
"gatsby-plugin-force-trailing-slashes": "^1.0.5",
"gatsby-plugin-gatsby-cloud": "^4.3.0",
"gatsby-plugin-google-analytics": "^4.3.0",
"gatsby-plugin-image": "^2.3.0",
"gatsby-plugin-launchdarkly": "^0.3.2",
"gatsby-plugin-loadable-components-ssr": "^4.2.0-beta.0",
"gatsby-plugin-manifest": "^4.3.0",
"gatsby-plugin-netlify": "^3.12.0",
"gatsby-plugin-netlify-cache": "^2.0.0",
"gatsby-plugin-offline": "^5.3.0",
"gatsby-plugin-preconnect": "^1.3.0",
"gatsby-plugin-prismic-previews": "^5.2.1",
"gatsby-plugin-react-helmet": "^5.3.0",
"gatsby-plugin-robots-txt": "^1.6.14",
"gatsby-plugin-root-import": "^2.0.8",
"gatsby-plugin-sass": "^5.3.0",
"gatsby-plugin-sharp": "^4.3.0",
"gatsby-plugin-sitemap": "5.4.0",
"gatsby-plugin-svgr": "^3.0.0-beta.0",
"gatsby-source-filesystem": "^4.3.0",
"gatsby-source-prismic": "^5.2.3",
"gatsby-transformer-sharp": "^4.3.0",

And Gatsby Source Prismic options:

resolve: 'gatsby-source-prismic',
options: {
  repositoryName: GATSBY_PRISMIC_REPO_NAME,
  accessToken: PRISMIC_API_KEY,
  customTypesApiToken: PRISMIC_CUSTOM_TYPES_API_KEY,
  linkResolver: (doc) => linkResolver(doc),
  shouldDownloadFiles: true,
},

Hello @rmatsumoto

Welcome to the Prismic community, and thanks for reaching out to us.

You have the correct setup in both your project code and the Gatsby Cloud settings.

It might be that you need to clear the cache of your project. Clear the cache, and re-build your project.

Let me know if it doesn't help.

Thanks,
Priyanka

@Priyanka No, clearing cache and rebuild still ended up with exact same error.

Found work around to this by manually exporting all the json schema from prismic and declaring inside of resolve: 'gatsby-source-prismic', under schemas: { ... }. With this, build went fine.

So there must be some issue around https://customtypes.prismic.io/slices and customTypesApiToken: PRISMIC_CUSTOM_TYPES_API_KEY,

@rmatsumoto Are you adding the correct token for the Custom Types API?
You need to add the one that appears in the same tab as the Custom Types API endpoint in your repository.

Just to pitch in, yesterday we started experimenting with Gatsby Cloud and the build went through around lunchtime.

I then tried another build in the evening and I got the same error message.

Production website on Netlify is still running fine, so there is def something related to Gatsby Cloud

@Priyanka env vars haven't changed and confirmed it is using correct token

@kris Yeah it looks like some kind of endpoint error on Gatsby Cloud's end.

They haven't cleared the error message yet, but haven't encountered same error yet this morning

Hello, @kris @rmatsumoto. It seems This incident has been resolved on Gatsby Cloud's end. Are you able to build your sites?