Page content is not updating

Hi there,

We tried updating some information and images as well as creating some new posts but when re-publishing it didn’t update. We tried a couple of times but the changes are visual only in when we go to the site like a normal user would we see the old information. I am adding some snips of the not published changes. How can we fix this?

This is an image we uploaded and it didn't change
Here it says that we made changes but nothing updated on the site
Please help us or give us some suggestions on how we can fix this!

Kind regards.


Welcome to the community and thanks for contacting us.

By looking at the snapshots given, the changes on Prismic are for locales Bulgarian, whereas on the site it is for en ( Did you update the content in the english locale too?
Could you please check on Bulgarian language on your site?

Let me know if you find any issue still?


1 Like

Hi Priyanka,

Thank you for the suggestion but it didn't work. I now have made changes in the English version as well but it didn't appear again.
These are some snapshots:

  1. Shows that I made the change in english
  2. Shows that the picture of the clock is changed but in the next snapshot, you will see that on the site after an hour from the change it is still the old picture.

    And this is not happening only with this picture it is happening with all changes that we try to make.

Kind regards.

It sounds like a cache issue.. Are you a developer? If not, you might need a developer to clear cache.
Please find more details in this article.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.