The "fetch" parameter doesn't seem to work

Hi, I’m trying to just fetch one field, using the fetch parameter, documented here.

Doesn’t seem to work.

I’ve not only tried title, but data.title, results.data.title, document.title, product.title, all with the same result.

Also your “product.title” example is a bit irritating, because there is no “product” object per default, the main data node is called “data”, so unless you’d have another nested object called “product”, that example doesn’t make much sense.

Please let me know if there’s a way to get this working.

Hi @christopher, sorry for the confusion. I’ll look into improving the documentation.

The way that fetch works is that you need to specify the API ID of the Custom Type and the API ID of the field. So, for example, if your Custom Type has the API ID of article and you want to retrieve the field with the API ID of title, then your fetch query option would be:

{ fetch : 'article.title' }
1 Like

Thanks @levi, that did it! :+1:

Improving the documentation about that would be helpful indeed.

Cheers!