Unable to sign into prismic with terminal on Mac

Hello,

I’ve been trying to test out prismic (with Nuxt) and tried to complete the sample site found here:


However, whenever I create the repo and project in terminal and try to connect to my prismic account. I get an error. I tried to sign in manually using just ‘prismic login’ and entering my credentials, but again the same error.
The error that posted was:
“This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled w
ith .catch(). The promise rejected with the reason:
TypeError: Cannot read property ‘split’ of undefined
at /usr/local/lib/node_modules/prismic-cli/bin/services/communication/index.js:42:42
at post (/usr/local/lib/node_modules/prismic-cli/bin/services/communication/index.js:48:4)
at Object.postForm (/usr/local/lib/node_modules/prismic-cli/bin/services/communication/index.js:90:12)
at /usr/local/lib/node_modules/prismic-cli/bin/commands/login.js:55:40
at processTicksAndRejections (internal/process/task_queues.js:97:5)”

Not sure why i’m receiving this error without actually having a project yet, presume it must be because I haven’t installed the correct package (i did install prismic-cli) or something wrong on the prismic side.

Looking forward to using prismic and appreciate any help i can get!

1 Like

I’m having the same issue but with the Prismic Gatsby starter. Any solutions?

Actually, it worked for me after signing out using the CLI. I was able to sign in and then run the theme command without issues.

1 Like

Same here. Tried using prismic login with Slice Machine. Same error. Logged out of my Prismic account, restarted the terminal. Still, no go.

DOY! prismic logout

Hi @diarmuidmcgonagle & others. I’m sorry that you’re having trouble with this. I’m not sure what the issue might be, so I’ll have to pass this over to @team-tech-support. Someone there will look into this and get back to you as soon as they are able.

I believe the theme command has been changed recently without us properly tracking the change. Can you try under prismic theme --theme-url [...]?

Sorry for the inconvenience :pray:

Hello @diarmuidmcgonagle, what is the version of the CLI that you’re using and the OS that you’re on? Could you try to update to the latest version, logout and login again please ? Thanks