customTypes not picking up deleted model and breaking

Hi,

I was modelling a navigation menu, decided I didn't like what I'd done and archived/deleted both the record and the model from prismic.

When I tried to restart gatsby develop it isn't loading as the source plugin is still looking for the old customType "header_nav".

I'm using the customTypesApiToken so it should pick up changes automatically (and has been up until now)

I'm not sure how to force it to get latest change (deleted model) or if there is something I need to do?

I've tried to gatsby clean, but that hasn't worked. I've double checked and the previous model has no records, archived or live and the model has not only been disabled but deleted too, so in the prismic backend doesn't exist.

Any help much appreciated as it has halted my dev this evening as I can't load up the gatsby site at all.

Hello Phil, thanks for reaching out!

This error occurs because you must manually provide the deleted Custom Types as an empty object to the plugin configuration. Here's an example of how to do it:

// gatsby-config.js

module.exports = {
  plugins: [
    {
      resolve: 'gatsby-source-prismic',
      options: {
        schemas: {
          my_deleted_schema: {}
        }
      }
    }
  ]
}

We'll make sure to add it to the documentation so that it's more clear.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.