Did not find Custom Type model IDs from gatsby-source-prismic

Hello Prismic community,

I've been facing an issue with the integration of gatsby-source-prismic and gatsby-plugin-prismic-previews in my Gatsby project. When I run my Gatsby development server, I encounter the following error:

"gatsby-plugin-prismic-previews" threw an error while running the onPostBootstrap lifecycle:
Did not find Custom Type model IDs from gatsby-source-prismic.

Here's a brief overview of my setup:

  • I have ensured that gatsby-source-prismic is listed before gatsby-plugin-prismic-previews in my gatsby-config.js.
  • My environment variables, including PRISMIC_ACCESS_TOKEN, are correctly set and accessible.
  • Both plugins are updated to their latest versions.
  • I have Custom Types defined in my Prismic repository, and they are correctly set up.
  • I've cleared Gatsby's cache and tried running the development server again, but the issue persists.

I've spent several hours trying to debug this issue, but I haven't been able to find a solution. I'm hoping someone here might have encountered a similar issue or can provide some insights into what might be causing this.

Any help or suggestions would be greatly appreciated. Thank you in advance!

Hey Team,

Are you sure you have at least one published document using the Custom Type you're trying to query?