No documents were returned - Dark Modern Website

Hi everyone, am trying to follow the tutorial with next js Dark modern website, but getting the error No documents were returned." my repo is above, would someone help me take a look at this? not sure if there is a issue with the starter repo or it is something I have done

I was watching TrostCodes video on prismic youtube channel, i finally set up my developement, but when i run it, my slice machine doesnt have another page and homepage slice , and the frontend has this error in the image below, how do i fix this

heres the repo : repo

@stevefernandes24 @junnexclusive I've taken a look, and I think that the issue here is that when you set things up, you selected a main/master locale other than en-us. The quick solution to this would be to duplicate the documents that you have in your en-us locale to your main locale (en-gb in both your cases). Then it should work for you.

Thank you Levi, that worked, was playing around with it more and understood why its happening. love the platform so far, I think that will be my go to freelance platform haha. thanks again!

1 Like

Glad to hear it :slight_smile:

Any luck on this issue.

I just tried following a very recent tutorial on Prismic/Next.js

Running WSL2 Ubuntu. Node version 20.10.0

When running the npx command

npx @slicemachine/init@latest --repository [MY-REPO-NAME] --starter nextjs-starter-prismic-minimal-ts

I get the same login error in the browser than @druharper was getting. I've been shopping for a CMS, took the rare time I have on a Saturday away from family to try to learn this stuff but running into a wall on the first step. No documentation or anything online I've found to help me past it.

Also tried installing the prismic-cli and running "prismic login" with the same result.

My repo dashboard tells me I still need to push up models:

Local Next build fails also with Unhandled Runtime Error:

Pay attention to your adblocker. I use UBlockOrigin and needed to disable it. Login worked fine.

Fixed the Unknown type error, something had gone wrong when running the first command and I just deleted the repo and started anew now that I'm logged in correctly. Frustratedly spent way longer than I wished on this getting started however lol.

Still running into the LinkResolver issue but I'll do some more research on that :smiley:

Did you get this to work?

I am trying to do the same tutorial, and from step one nothing works. After I run this command:
npx @slicemachine/init@latest --repository dark-design --starter nextjs-starter-prismic-minimal-ts
it won't let me login from the terminal. in the console there is a cors error.

and if i try to run npm run dev I'm getting the same unhandled runtime error that you have shown above.

Hi @jason.kei.hall @dev.davebarrett ,

Welcome to the community :slight_smile: I'm sorry to see you ran into these issues, I'll be happy to try and resolve them with you.

I moved your questions here because it seems like the same issue. I checked your repos and can see you both have the correct documents in the correct locales.

Are you still seeing the issue?

A post was split to a new topic: Error creating Slice - Dark Modern Website