Npx @slicemachine/init wrong APIEndpoint

Hi there :slight_smile:
Today I encountered an error when initializing the slicemachine in a Nuxt project.
After connecting the slicemachine to my repo, the init command inserted the respository name instead of the API endpoint (see screenshot below)
Best regards
David

Hi @nativv,
Thanks for reporting this issue, I'm followed the docs and it is working for me:

Have you tried to update prismic-cli to the latest version? and you getting any errors?

Can you write this command line and give us the result:
prismic -v

Looking forward to your reply,
Fares

Hi Fares,
Thanks for the reply.
I retried using the current version of prismic cli (before I was using v. 4.0) and still get the same behavior. The API URL should be: https://testslicessite.prismic.io/
This is my terminal output:

prismic -v
prismic-cli/4.2.2 darwin-x64 node-v16.14.0

I followed the Slice Machine Nuxt Docs:

  1. I created a Nuxt project using npx create-nuxt-app
  2. After, I initialized SliceMachine using npx @slicemachine/init

May I know what OS you are using?

Sorry for my late reply. I'm using macOS 12.1 Monterey
Screen Shot 2022-02-18 at 15.47.43

Hi had the same problem.
Init take the Display Name of the repo instead of the endpoint.
I just changed.

It just works only if the display name is the same.

Thanks for reporting the issue, we have already created an issue in our tracker, and we will let you know in the case of any updates.