oEmbed for Instagram/Facebook broken from Facebook API changes

Topic title. On October 24th, 2020, Facebook roled out some changes to how they handle oEmbed for Facebook and Instagram posts. They now require authentication with an Access or Client token for oEmbed. Since these changes, Prismic no longer takes a FB/IG post URL for embeds, nor does it recognize the new oEmbed URLs as oEmbeds. Any guidance on how to proceed would be excellent :pray:

Heres some docs explaining the new API requirements:


Hello @devon.noeldetilly and welcome to the Community forum !

This is a known issue we are tracking since today morning. We are investigating further at the moment and once we know more on what could be causing the issue I'll update you here.

Sorry for any inconvenience this is causing you.

@ehyslop is having a similar issue:

Awesome, thanks team, appreciate the quick response. I await your update, let me know if you need any other details. :v:

1 Like

Is there any update on this issue? Causing us quite a big problem for our site which makes extensive use of Instagram embeds.

Is there any update on this? This is a major issue for us. Thanks.

Hello everyone, just to let you all know that we've categorised this issue as a priority an we'll be addressing it soon. I'll come back as soon as I have more news.

Thank you

[Update] This should be fixed now for everyone.

If anyone has any issues regarding this same topic please add a comment in this same thread.

Thanks!

Twitter embeds are still broken throughout the site for us, and I've had no response to PMs with your team in ~5-6 days.

Hi @ehyslop,

Can you try re-publishing a document or clearing the cache in your application to see if it triggers the fix?

Thanks.

Hi, thanks for your help, apologies, this is an unrelated issue that coincidentally occurred at the same time as Insta/Facebook embeds stopped working. This does not seem to be a Prismic issue. Thank you for your help.

1 Like

No worries Eilidh,

We're happy to help, let us know if you run in to any other issues :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

I just tried linking an Instagram post and didn't work for us. I received this error:

"This endpoint is deprecated. Please read https://developers.facebook.com/docs/instagram/oembed to learn how to migrate your endpoint."

Hi @wylkon.cardoso , usually this is solved by re-publishing a document in your repository and clearing the cache in your project. Could you try this and see if it helps?

Thank you for the answer! Yes, we did that, and also we changed the Instagram post URL and re-published the document. It is possible to notice the new Instagram URL, but still returning that error.

I see, I'm asking the team about this. I'll get back to you as soon as I have some info

Thanks

1 Like

@wylkon.cardoso Could you please send me the URL in question, and the URL of your repository? in a private dm if you prefer.

Thanks