Preview not working on Macs

Hi,

When loading a Preview on any browser on a Mac, the toolbar /edit pencil icon does not show up. On a Windows PC it works ok. I have the same issue as this post here - {repoURL}/toolbar/state is returning a 404; Previews not working - #9 by Phil
So do you need to make the same fix in my repo ? Thanks.

Just an update. The Preview now does not work on PCs either. One additional error I see is:

iframe.html:16
Uncaught Error: Unexpected message received by the iframe: [object MessageEvent].
Expected setup_port
at Object.initialisationMessageHandler (iframe.html:16)
at iframe.html:16

10:38

from Prismic Toolbar iFrame

Hi Long Pham,

Can you give me the name of your repo so I can check this?

Thanks.

Hi Phil,

The name is museumofthebible. Thanks.

Can you check this now?

It seems to be working but for one of the new custom type, we are seeing a 404 page, but the 404 page has the preview toolbar.
Here is the custom type page - https://museumofthebible.prismic.io/masks/location_site.json/

I don't understand, where are you seeing the 404?

Sorry for the confusion, if you go to https://museumofthebible.prismic.io/documents~b=working&c=unclassified&l=en-us/YEGBCRIAACYAbyoE/ and click on Preview, you end up on a 404 page.

OK, it sounds like you haven't updated your link resolver to process the new custom type.

You can check this and other common preview issues here:

Ok, yes, I see the problem there. Thanks.
Also, the preview toolbar is not showing up on a Mac in Safari. Chrome is working now. I tried this in the incognito mode of Safari.

It won't show up on a browser on which you're not signed in to Prismic.

I'm signed into Prismic in another tab. I tried this on an incognito window as well as a regular window as well.

If your previews are working everywhere, but not in Safari, then the issue is an easy fix. Safari released an update that blocks cross-site cookies. Our preview system uses these cross site cookies to build the previews on top of your web app, so you will need access your Safari preferences > navigate to the privacy tab > deselect 'Prevent cross-site tracking'.

That works, Thanks !

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.