Prismic New does not work on Windows, Debian or Ubuntu

I'm trying out Prismic after struggling with Strapi for awhile. I've installed the prismic-cli under 2 different OS's and it has not worked either time.

OS I've tried - Windows 11 via CMD prompt, Debian and Ubuntu via WSL2
When running prismic new to create a nuxt project I get the following errors when it get to the Developer Tools point
1 - no username for email address
2 - no email address

prismic whoami command returns the correct email address for my account.
prismic login seems to be working correctly.

Hey James, thanks for reaching out.

Can you tell me which version of the CLI you are using? You can check by running prismic -v in the console.

prismic new should prompt you the fields to enter your login details.

prismic-cli/4.1.1 wsl-x64 node-v16.9.1

Ok, thanks for sending over this info.

I've informed the team and we're going to try and run a test on our end.
We'll come back when we have more information about this.

Thanks

Thank you.

FYI - I was also having an issue with the prismic theme command not working. I switched to 14.17.6 as suggested by one of your colleagues, that got the prismic theme command working but prismic new still fails with email required. I had already been authorized by the cli when running the prismic theme command.

Ok, thanks. I'll share this with the team.

Hi,

Just to confirm. The issue happens during the ? Development tools: prompt?
Are you making any selections?
Is this in the display of the cli?

1 - no username for email address
2 - no email address

I am wondering if having a git email / username configured will fix the issue.
Can you check if there's any out put from git config user.name and/or git config user.email?

if not then try git config --global user.name "jamesnobles" and see if that works.

I'm asking because part of the nuxt setup prompts tries to get a users github username or email address, and I'm thinking that might be it.

Thanks :slight_smile:

Debian:

Turns out I did not have git installed! On Debian I always forget that git is not installed by default like Ubuntu. Once it installed git and setup git config user.name and user.email it completed the setup.

Storybook now seems to work as well, npm run storybook now works as well. Maybe the prismic theme command for the nuxtjs/storybook/slicemahine option was quitely failing at some point without the git config as well? I can now install prismic/nuxtjs with slice machine and get storybook started were as before I was getting errors about missing storybook/vue folder and files.

Ubuntu:
Node 16.8.0 and 14.17.6
On Ubuntu I set up user.name and user.email and got past the missing username/useremail error. Now i get a new error using prismic new or prismic theme.

Is there still an error?

Yes, on Ubuntu. I copied the error from the terminal and pasted at the end of the previous email. I'll copy it again below.

create slices/index.js
npm ERR! code ETARGET
npm ERR! notarget No matching version found for @babel/plugin-proposal-object-rest-spread@^7.15.6.
npm ERR! notarget In most cases you or one of your dependencies are requesting
npm ERR! notarget a package version that doesn't exist.

And this is with a nuxt project?

Can you install the beta version of the cli and confirm if the issue is still present?

npm install -g prismic-cli@beta

Thanks :slight_smile:

I got the same error when using node 16.8.0 but when I switched to node 14.17.6 everything worked. I was able to use prismic new to setup a nuxt project without slicemachine and I was able to use prismic new to setup a nuxt project with slicemachine, plus storybook worked as well.

Well it's good to know you got it working :slight_smile:
I'll take a note about this issue

Thanks