Slice Zone suddenly empty

Im working on a nuxt project that's been fine until now.
Have a lot of documents that's been working as intended since december.
Today I updated to slicemachine 0.2.1 and added slice simulator to get som prints of the slices for my client. That's when all slice zones stoped working, and I just get the "slice zone is empty" message with no errors in the console.

I've tried reverting to the former slicemachine version but it's still not working.
Any ideas on whats going on or where I should start troubleshooting?

Best regards,

Update: By going back to vue-slicezone 0.1.0 and slicemachine 0.2.0 i got my slicezone back.

Same here, slice machine broken again after the last update. Reverting to 0.2.0 fixed it.

Hi Team,

I'm sorry to see you're facing this problem.

Does this sound like your issue?

I've reached out to the devs to see what they may have changed.


I was just taking screen shots in slice simulator when I noticed the slice zone wasn't working. Just before I had upgraded the slice machine. But then I looked in the node modules for vue-slicezone and couldn't find any logic for the slice zone, which I could find in vue-slicezone 0.1.0 so I tried downgrading it and then it all worked again. Hope it helps in figuring out whats up :slight_smile:

Can you show your Slice Zone code? Maybe in your Github repo?

Also, can your share with me your repo URL?

So I think we found the issue. In the latest update vue-slicezone the prop that accepts the slices data seems to have changed from body:

<slice-zone type="homepage" queryType="single" lang="fr-fr" body="body"/>

to slices:

<slice-zone type="homepage" queryType="single" lang="fr-fr" slices="body"/>

Does this look like what happened for you?


Might been, I've never used the body attribute on the slice zone, though.
I only use it like this: <slice-zone type="homepage" queryType="single" lang="sv-se" />

Hey Hannah,

Sorry about the long delay with the reply, the team rolled back an update to the vue-slicezone package which seemed to have caused this issue for you. Can you try updating this package again?