SliceMachine + RichText validContent error

I have created a slice with a RichText field, the model is saved locally and pushed Prismic.

Whilst in the CMS however, after adding the RichText slice to a document, I am unable to fill in any content longer than the first text / element.

When adding a RichText field to a document (not through slice machine) I can successfully use line returns, add additional headers and paragraphs as expected.

There is a console error being raised:

Uncaught TypeError: Cannot read property 'validContent' of undefined
    at t.canSplit (main.js:370)
    at Array.B (main.js:334)
    at main.js:334
    at n.<anonymous> (main.js:456)
    at main.js:456
    at k.someProp (main.js:456)
    at N.keydown (main.js:456)
    at HTMLDivElement.e.dom.addEventListener.e.eventHandlers.<computed> (main.js:456)
    at HTMLDivElement.a (main.js:329)

The project was created using slice-library-starter-next.

Any insight or help would be much appreciated.

Hi Dan,

Welcome to the community!

Can you show me what your Slice looks like?


Hi Phil.

So my slice is setup as follows:

I've just added a richText field with a different field ID, but the editable rich text fields when editing the document within the CMS still throw the same error.

OK, can you try updating to the latest version of the next-slicezone plugin?


next-slicezone updated to 0.1.0
Slice model saved locally and pushed to prismic

Same error still being raised within the CMS

OK, in that case, can you send me the URL of your repo and a zip file or Github repo of your project so I can test on my end?

This thread has been closed due to inactivity. Flag to reopen.