Starters not working

Tried to setup starter projects but all three fail with 500 internal server error. I followed all the steps (except for the blog which seems to generate and publish sample content as soon as the slice machine pushes custom types to prismic).

I am sure I am missing a crucial step somewhere, just not sure where. Thanks in advance for your help!

Hi @mika,

Can you please send me a zip file of your repository and your repository name (in a private message if necessary), and I will try to run the project on my machine.

Hi @Fares ,

Thank you so much for offering to help with this. My prismic repo name is mikas-blog-example (

The code i am running is as generated by the script from the starter page (npx prismic-cli@latest theme --theme-url --conf sm.json) I have not changed a single character in that code. The content is also as generated by the "push to prismic" action in the slice machine.

I cannot attach the code as even without node_modules the zip is 12MB.

Hi @Fares ,

here is the code without .net/cache/webpack ... Hope that is OK for you. (2.2 MB)

1 Like

Hi! I have exactly the same issue

Right... I think I will get a red herring poisoning, but it is all solved now.

For the blogs example, open Settings type page and add some content to the Newsletter Description and Newsletter Disclaimer fields. Publish and run. It should all work just fine.

Please note that you can then delete the same content, republish and it will all work fine, so I do not think it is the lack of content which is the problem. If I was to guess, I think that the content build scripts do not populate all the fields properly with default values.