500 Error When Using a Preview Ref

Suddenly we are seeing a 500 error when submitting a GraphQL query with preview refs. When I submit the same query using our master ref, we receive a valid response, but when using a preview ref we see the error message seen here - https://d.pr/i/mMA80R

Could this mean something is wrong with our content? We tried to archive our major content changes and preview with simple tweaks (changing words only) and are still getting the same error.

Hello Brent! welcome to the community forum!

Let’s make a few checks:

  • Have you configured the previews both in the repository and in your project? We have a troubleshooting article for previews
  • Is this the first time you’re having issues with this?
  • How are you passing the preview ref? If you have screenshots of code snippets it’l be very useful

Hi Paulina, thanks for your response!

We’ve had previews set up to work for some time, and this is the first time we’re seeing this error.

From the troubleshooting article, I am building a link to test with the REST API, and seeing the error in the screenshot here - https://d.pr/i/U2AU6K

I’ve crossed out our repo and ref but would provide that via private message if it is of more help

Yes that’ll be really useful. I’ve sent you a message

This issue has been closed due to inactivity.