Cannot Login Via CLI - › Warning: current base is set to https://prismic.io/

Describe your question/issue in detail

Cheers,

I'm unable to login via CLI. When I execute prismic login, I first receive this message:

 ›   Warning: current base is set to https://prismic.io/
Prismic: Press any key to open up the browser to login or q to exit: 
Opening browser to https://prismic.io/dashboard/cli/login?port=5555
Prismic: Logging in... ⡿ Waiting for the browser response

Then I'm directed to the browser, where I get the error:

"Oops - It looks like you are trying to log into Prismic through your terminal, but something has gone wrong. You can try again by running prismic login from your terminal. If the issue persists, please post on community.prismic.io"

Repo: cacoon-slicemachine

Impacted feature

What steps have you taken to resolve this issue already?

Errors

Your Role

Engineer

Hosting provider

Vercel

Package.json file

Steps to reproduce

Hi There! Simple quick question to see if this might help. Have you tried running prismic logout and then prismic login that used to be a trick that would help me when my login status was acting funky.

Thanks for the quick response @nf_mastroianni . Unfortunately, that did not change the situation, I'm receiving the same error.

@createcacoon Can you report back your installed CLI version?
FWIW, this is me:

prismic --version
prismic-cli/4.2.3 wsl-x64 node-v20.11.1

Here's what I'm workin' with:

prismic --version
prismic-cli/4.2.3 darwin-arm64 node-v18.18.2

This is still an issue, I cannot save my new additions.

Hi @createcacoon, I'm sorry you're still having this issue. I've never seen this error before.
Have you, by chance, attempted to spin up another project just to see? Have you tried cloning your project on a different device to see if it has anything to do with your environment?

Ok so, for laughs, I decided to try using GitHub Codespaces to test out their environment. I did get a similar error to what you mentioned. I believe this has to do with the environment though. My logged in state on my local machine is not able to be seen by prismic-cli in the codespace instance.

I'd be very curious if you could test your setup on a different (but still local) machine.

Interesting thought, I suppose I will have to try.

What I did try: I would log out, log back in. I created a new account, transferred project ownership to the new account, then tried logging in; same issue. I did this again with another new account, same issue. Transferred back to the original account, still an issue.

I can try with a new project, I suppose. I can also try same project, different machine. I will circle back.

1 Like