Double spacing when copy & pasting content into Prismic

Dear Prismic Team,

when copying&pasting content from websites or .doc into Prismic, there often occurs a double space instead of single spaces between words. Any idea to avoid this?

Hi Jens,

Thanks for reaching to Prismic community,

In order to be able to help you on this we need some extra informations!

Can you post here an example of a text that is showing 2 spaces instead one, is this behaviour is deterministic? meaning that every-time you past the text you get this result?

Also did you try to check if the text you are copy pasting don’t have Non-breaking spaces or any other hidden characters?

Fares

Hi Fares, thanks for the quick reply.

Take this text block for example:

“Bei Dress-for-less haben Sie die Möglichkeit, hochwertige Kleidung zu günstigen Preisen zu erhalten. Noch günstiger wird es aber, wenn Sie einen Dress-for-less-Gutschein einlösen. In dem Fall reduziert sich der Gesamtbetrag in Ihrem Warenkorb noch einmal deutlich. Wenden Sie den Dress-for-less-Gutschein dafür einfach online an. Wählen Sie die gewünschten Produkte aus und legen Sie diese in der gewünschten Größe in den Warenkorb. Gehen Sie dann auf den Warenkorb. Hier sehen Sie Ihre Auswahl und können darunter in das freie Feld den Rabattcode eingeben. Lösen Sie diesen anschließend ein. Sie sehen dann Ihre Ersparnis.”

It comes from https://www.gutscheine.de/dress-for-less/.

And this is what I get in Prismic:

“Bei Dress-for-less haben Sie die Möglichkeit, hochwertige Kleidung zu günstigen Preisen zu erhalten. Noch günstiger wird es aber, wenn Sie einen Dress-for-less-Gutschein einlösen. In dem Fall reduziert sich der Gesamtbetrag in Ihrem Warenkorb noch einmal deutlich. Wenden Sie den Dress-for-less-Gutschein dafür einfach online an. Wählen Sie die gewünschten Produkte aus und legen Sie diese in der gewünschten Größe in den Warenkorb. Gehen Sie dann auf den Warenkorb. Hier sehen Sie Ihre Auswahl und können darunter in das freie Feld den Rabattcode eingeben. Lösen Sie diesen anschließend ein. Sie sehen dann Ihre Ersparnis.”

Most likely it is a formatting issue coming from where you are copying the text, can you try to use the ‘Paste and Match Style’ option and check if it solves the issue?

Hi Fares,

I assume you are correct - unfortunately paste and match style in Windows is a little unwieldy.

I will think of a workaround. Thanks for you help!

On a side note: Since double spaces are usually unwanted, maybe future versions of Prismic might filter/mark them somehow.

Hi Jens,

Thanks for letting us know, I don’t think it is a good idea to filter out a sequence of spaces as some clients use this for some specific use-cases.

Fares