[Fix Waiting to be deployed] Unable to save document when Slice is empty

hello, @Phil and @lejardindesfunambule

I encountered the same problem. I tried to delete the slice with

curl --location --request DELETE 'https://customtypes.prismic.io/slices/TextSlice \
--header 'repository: tutorial-series' \
--header 'Authorization: Bearer  ...

witch works great and tried to upload shared slice again with image which returned success.

Screenshot 2021-03-26 at 13.12.47

Two bugs occurred

  1. Wrong image
  2. If I try to use this slice inside a page, the page won't be saved.
    API response returns:
    error message below
Unable to save version: 
List(JsError(List((/key/value,List(ValidationError(error.path.missing,WrappedArray()))))))

Maybe useful information:

  • currently using prismic-cli version 3.8.9
  • repository name https://oxylabs-sm.prismic.io/
  • broken slice name: SocialProofAccountManagers
  • You can see bug at our repo in page type Solutions page name testing

Edit: added how to replicate bug.

How to replicate create slice with SM, add custom image and publish to repo.

1 Like

Hello @Phil

Sorry, for late response.

Slice preview images works great with slice-machine-ui 0.0.45, but I still get error while trying to save file.

Unable to save version: 
List(JsError(List((/key/value,List(ValidationError(error.path.missing,WrappedArray()))))))

Maybe I should create this as new issue?

Answering to your question

@juskeviciusarn You tried to upload the new Slice from the Slice Builder or using the Custom Types API?

I uploaded slice from slice builder.

Hello once again!

After some testing I found out why I was gettiing this error.

The reason was my slice was empty (see image below)

Is this how it's supposed to work? Because from a user's perspective it is unclear why the page can't be saved.

The error does not specify why it cannot be saved.


After testing and breaking it a little more, I found that if I save the slice with some text...

...and then later delete the text and save it once again, the slice saves without any errors.

OK, it shouldn't behave like this. I'm bringing this up with the devs now.

@juskeviciusarn Can you tell me the URL of the repository where you are seeing this?

@juskeviciusarn I talked with the team and it seems this is a known issue with a fix waiting to be deployed.

@Phil thank you for fast response! :heart: