Legacy Builder Enabled By Default

I am spinning up a new NextJS project using the following commands:

yarn create next-app --tailwind
npx @slicemachine/init@latest

When I go to the prismic repo and select a language, I noticed that all new repos have the legacy builder enabled by default. I am not able to find away to disable this legacy builder as well.
I prefer not to have the legacy builder available at all as this can be confusing for clients. They start editing custom types and they they're creating content. What am I missing?

1 Like

Perhaps I am the only one who is noticing this issue, however. I have a workaround that appears to allow me to create Prismic repos using slicemachine without triggering the Legacy Builder. Below are my commands for spinning up a new NextJS+Prismic project:

yarn create next-app --tailwind
# cd into your new Next project
npx @slicemachine/init@1.1.13
# create a new repo
# run the init again but with the latest version
npx @slicemachine/init@latest
# this migrates the project from using sm.json to slicemachine.config.json etc

If this helps you too, I would love to hear from you. :innocent:

I noticed the same problem as you.
In my recently created Prismic repo now suddenly appears the UI of the legacy builder.

I have no idea how to deactivate it, but would be happy if we were able to...

Sadly Andre, I don’t believe there’s a way to disable it. You may need to delete the repo and try my workaround.

I hope that's not the case.
Does anyone from @Prismic-Support-Team / @Pau have a solution?

1 Like

Agreed. Let’s hope someone can weigh in on this like maybe @Priyanka ? :pleading_face:

Did you create the new repository from the Slice Machine command or from the Dashboard?
Some repositories have a toggle option to disable the Legacy Builder. You can find it in your repo's Settings > Repository.

@Pau
Yes. At the time of the post, I created the next project as I usually do (code in the original post). The legacy builder was in the left sidebar, and when I went to the settings of the Prismic repo, the toggle was not an option.

I also created the Repo in the terminal, I guess 3 weeks ago.
Last week then suddenly the legacy builder navigation appeared...

I don't have the option to toggle it off:

Looks like it must just be me and you Andre. Bummer

I don't hope so...
It must be something the dev team of Prismic made on their server or in a package, as I'm sure I didn't change a thing.

At least I hope someone from Prismic can disable it for our repositories manually, @Pau / @Priyanka ?

Hello team. Can you send us via dm the details of your repository? you'll see a message in your inbox to send it. Thanks

1 Like