Local Slice Simulator not working

I'm trying to run the slice simulator in on my local but when I enter "http://localhost:3000/slice-simulator" as a url I get an error on the page that says:

TypeError: t.partial is not a function

This error happened while generating the page. Any console logs will be displayed in the terminal window.

Also when I try to create a slice and I go to Model Content with Next.js - Prismic and follow the steps, I dont see a button that says Open Slice Simulator. When I run npm run slicemachine and go to the Slice Editor and click Preview Slice, it says configuration not complete. Step 2 is not setup, even tho I have copy and pasted and followed instructions.

I am using Nextjs

Thanks for any help on this!

Hello @randyrollog

Welcome to the Prismic community, and thanks for reaching out to us.

To Preview Slices in the Slice simulator, here are the steps:

  1. Create Slice Simulator page in your project.
  2. Add a property for the Slice Simulator URL in the sm.json. This should be: "localSliceSimulatorURL": "http://localhost:3000/slice-simulator"
  3. Simulate the slices to see what it looks like in your development environment. Ensure your app is running on another terminal: npm run dev. You need to run npm run dev on another terminal.
  4. Now, on the Slice editor page on the Slice Machine, click "Preview Slices".
    You should now see a simulated preview of your Slice with mock data.

Let me know if it still doesn't solve your issue.

Thanks,
Priyanka

hi @Priyanka

I've ran through this multiple times. But I'm still seeing the error that the configuration isn't set up. But it is...

Heres what I see when I go to localhost:3000/slice-simulator

Hello @randyrollog

It's difficult for me to troubleshoot your issue without your project source code. You can share it with me by private message.

Thanks,
Priyanka