We can’t connect to the simulator page

I'm trying to create a prismic project with next from Setup prismic

But when i try to create a Slice and preview it, for some reason I get this error:

I followed all the steps from the docs, including adding "localSliceSimulatorURL": "http://localhost:3000/slice-simulator" to sm.json; slice-simulator.jsx has the same content as in the docs. When I open http://localhost:3000/slice-simulator, it shows this:

My node version is 14.19.1, but i also tried 16.15.0.
This is the source code: GitHub - mlshv/prismic-not-working-repro

By the way, the link to 'troubleshooting page' from the first screenshot redirects me to a page that has nothing about troubleshooting :man_facepalming:

UPD: seems like the problem was on my side: for some reason it doesn't work in Sidekick browser, but works in other browsers. Still, missing troubleshooting page link got to be fixed

Hello @mlshv42

Welcome to the Prismic community, and thanks for connecting your project with Slice Machine.

I am glad your issue has been solved, and thanks for pointing out the troubleshooting page link; we will update it.


Hello @Priyanka

I've just set up another project and now I have the very same problem, but now it is in all other browsers I have, including Safari. In the console, I get this error:

Is there a chance that something in my project configuration doesn't let SliceMachine open the page? Because the page is there, I can see it.

And in my Next console I see event - build page: /slice-simulator when I try to preview the slice.

What do I do?

@wes.gilmour Can you tell me the version of the node?

Same, tried 14.19.1 and 16.15.0.

Can you send me your project source code and Prismic repo Url to reproduce it on my local system? You can send me a private message, though.

I'm afraid I can't share the code since it is under NDA :confounded:

Hello @mlshv42

In that case, could you check these:

  1. Repo name URL is correct in the sm.json file.
    2. npm run dev is running on another terminal.