Nuxt.js Preview failing on Netlify

Hi @Phil
I'im also using nuxtjs with target is static to deploy on netlify server
But preview not working, return 404 page always
but I did test on my localhost then working fine
:frowning:

Hi Hung,

Welcome to the community!

Can you tell me if you have this fallback set up for Netlify in your Nuxt.config?

Are you using the @prismic/nuxt module?

Hi @Phil
Yes, Im using the @nuxtjs prismic module with fallback settup as like above
Please tell me know if it is wrong? Or I need to change any thing? Thanks! ^^

This issue is due to @nuxt/ufo which is a new URL handling helpers that got introduced in nuxt@2.14.12. Everyone that installed this patch since its release (16th of December) and before the 6th of January inherited the bug which has now been fixed with @nuxt/ufo@^0.5.3

To fix this issue users need to run npm update or yarn upgrade , this will bump the package version and fix it :slight_smile: (If this doesn't work, delete the package-lock.json & node_modules then run npm i)

I dont think so because my local is working and only not working when deploy it on Netlify
So strange

Did you check your version of ufo?

I didn’t see ufo in package json file :confused:

It should be in the package-lock.json

"@nuxt/ufo": {
"version": "0.5.4",
"resolved": "https://registry.npmjs.org/@nuxt/ufo/-/ufo-0.5.4.tgz",
"integrity": "sha512-JZOGDlt2BvLCBmLhrchhRJ6tP9PBfSWLdsHC+JVJ5Qp8/hT/2u61cSsLS30zUOwcPRaQ3y2oHNkEiKJ5v90iEQ==",
"dev": true
},

"version": "0.5.4" but it's still not working :blush:

and as I mentioned it was worked when I preview by localhost with mode dev
And not only working when I deploy to Netlify with mode Prod ( nuxt generate)