Nuxt.js + Prismic configuration: dependency not found

Hi, I have tried to perform the configuration steps as described here but I am no longer able to run "npm run dev" in my nuxt project due to the following error:

This dependency was not found:

  • @prismicio/vue/components/common in ./.nuxt/prismic/plugins/prismic-components.js
    To install it, you can run: npm install --save @prismicio/vue/components/common

Nuxt version: Nuxt @ v2.15.3
Npm version: 6.14.11 (node ​​v14.16.0)
Prismic version: 3.8.9

I tried to install "npm install --save @prismicio/vue/components/common" but it doesn't solve the problem.

Any suggestions?
Thank you!

Hey Matteo,

The build version 2.0.8 of @prismicio/vue was messed up, but it was fixed in version 2.0.9.

The fix is simple run:

yarn upgrade @prismicio/vue@^2.0.9

or

npm update @prismicio/vue@^2.0.9

Or delete the node_modules & the lock file and install again :slightly_smiling_face:

Thanks.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.