Prismic Preview toolbar and edit button doesn't appear on some pages


I am developing with NuxtJS and vue with PHP as a back end. We are running a statically generated website and using Prismic Previews.

I think this issue was mentioned by other users here before but there are some pages where the Edit Button won't load or disappears.

There was a workaround to call the same API again after load to view the edit button but that hasn't worked for me.

Can anyone help me with my issue?

Many thanks.

Hi @sog ,

Thanks for reaching out.

Normally integrating the preview feature is strait forward with Nuxt.js if you are using the @nuxt/prismic module, but this might depend on the platform you are using to deploy your application.

And in order to troubleshoot this issue, I would need more info such as the platform your using and some code sneppit of your Preview implementation.

Also have you tried to test the previews locally, and can you link to the similar thread you have mentioned?

Looking forward to your reply,