Slice machine custom screenshots not updating

Hey, could you please help me understand why my custom screenshots aren't being successfully pushed to my prismic repo? The preview.png is the exact same inside my CtaOne slice folder by the way.

1 Like

Hi Team,

It seems you adding the custom image in the ~.slicemachine/assests/slices/CtaOne/preview.png folder. This is where the automatically generated images are stored.

To overwrite this image you must place your custom image in the ~slices/CtaOne/preview.png folder.

Try this out and let me know how it goes.


I wasn't very clear before but I have the same .png inside the slice folder as well, thx for your time btw

No problem. So when you click refresh screenshot, this appears? Can you try making a small unnoticeable change in the slice to see if that triggers the correct image being pushed?

Where do I click refresh screenshot?

When you hover your mouse over the image the button should appear.

I only see "Take screenshot" and "Custom screenshot" options

OK, I just tested on my side and I'm getting the same result. This is obviously and error so I'm going to pass this to the dev team and see what the issue is.

Thank you Phil, have a nice day :slight_smile:

1 Like

You too, thank you for your understanding.

1 Like

So I talked with the Slice Machine team and they're aware of this issue. It's because of how the images are stored in the imgix cache, they have the solution & hopefully it'll be fixed soon.

Do you mind if I make this thread public so other users can find this information?

1 Like

Sure, you can turn it public, no problem.
Did they tell you when, approximately, they're planning to have this bug fixed?

1 Like

This is being tracked as an open feature request.

If you have another use-case for this feature, you can 'Flag' this topic to reopen. Please use the :heart: button to show your support for the feature and check out our Feature Request Guidelines.

Hey ! Any news on this ?

Hi @optimate & @lejardindesfunambule ,

Sorry for my lack of communication on this. I believe this was updated. Can you try updating to the latest version of the slice-machine-ui and testing by recreating a new screenshot?


Hi !
I made a new try with the last version of slice-machine-ui (V.0.0.44) and it seems that it is still not working.

OK, I'll look into this with the team and get back to you.

1 Like

@lejardindesfunambule Can you try renaming the Slice or creating a new similar one to see if the new image is generated?