[Solved] Remove some result from tag

Hi,

Is it possible for me to remove some tag as it is not anymore in used?

image

No, see the bottom of this documentation: https://intercom.help/prismicio/en/articles/2690038-prismic-s-default-tagging-system

Prismic currently doesn’t have any sort of tag management management system. This means that you need to be careful when adding tags to your documents because you can’t delete or modify a tag after it’s been created.

You’ll need to note the following:

  • You can’t permanently remove tags from the system, even if you remove a given tag from all documents.
  • You can’t modify a tag after it’s been created.

Hi Team,

I believe the above documentation is out of date. We created a fix for the tags in the default tagging system, this fix means they will automatically be removed if they are no longer used in any documents.

We’ll need to update this document.

@likhit_prismic-custo Can you send me a private message with the URL of your repo so I can check this for you? Some older repos might not have received this update.

Thanks.

2 Likes

That’s great news! Thanks for letting us know :+1:

Update: If you have any archived or planned documents using the tags, then you will also delete those to clear the tags.

1 Like

This issue has been closed due to inactivity.

Hi Everyone,

Quick update for older repositories, removing a tag from all documents should now remove it completely from the repository.

Thanks.

Continuing the discussion from [Solved] Remove some result from tag:

Someone from Prismic said "Quick update for older repositories, removing a tag from all documents should now remove it completely from the repository."

This is not the case. We have at least one tag that is appearing in tag filter list (on the main /documents/working view) and also as an auto-complete option (when editing tags on documents) that is not currently being used on any working or archived document.

Hi Jennifer,

Welcome to the Prismic community.
I have moved this thread to the original post and opened it.
Can you please share with me (in a private message if necessary) your repository name as well as some screenshots and links, if possible?

Looking forward to your reply,
Fares

Fares - I have sent you a direct message with the information that your requested.

1 Like

Hi @jennifer we are still investigating this issue and we will get back to you ASAP.

Hi @jennifer ,

I'm taking over this thread from Fares.

Have you tried deleting the tags from any 'archived' or 'planned' documents? This is usually the sticking point for this one.

Thanks.

Yes, we have. My original direct message to Faris demonstrated that there was no active or archived content tagged with the erroneous tag.

  • Jennifer
1 Like

Hi Jennifer,

I'm back from my vacation, the issue I have created for this is being worked on currently, and I will let you know once I have more info.

This thread is being monitored as an open ticket in the issue tracker. We will update this post as we get more information. If you have a similar use-case, you can ‘Flag’ this topic to reopen.

Hi @jennifer, I have checked, and in fact, you had a document in the archive tab that belongs to the tags with space; once I've, I totally deleted this archived document. The tag disappeared:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.