Start-slicemachine is not recognized as an internal or external command after upgrade of slicemachine-ui

Currently updated to slice machine 1.0.2 and I am having trouble running it when I run pnpm start-slicemachine.

Error : 'start-slicemachine' is not recognized as an internal or external command,
operable program or batch file.

I appreciate your help. Thanks

1 Like

have you tried running npm run slicemachine?

Turns out this is a pnpm issue. Changing to npm, and all works well. Can't figure out why it is happening.


I have the same problem, after installing and configuring the slicemachine "pnpx @slicemachine/init@latest", when running the script "pnpm run slicemachine", the error occurs:

ELIFECYCLE Command failed with exit code 1.


Shift your the project to use npm for now. Hopefully the prismic team will fix this soon.
An issue was opened on this topic - Link

I have the same issue with yarn.

:clap: :clap: Now fixed for pnpm and yarn in the latest release of slicemachine 1.4.0