Unable publish new content for a single type

I have a page called "privacy_main_page" with a content block of HTML content. When we tried publishing a change earlier today we got an error and were asked to "retry publishing". Ever since then, every time we publish changes they don't ever take effect. It's only ever giving us the content from before this morning. I think we need some help here in seeing why we can't get this page to publish updated content.

Some Things to Note:

  1. We have other pages we have published changes to and they seem to be working alright.
  2. When running "gatsby clean && npm start" the content being retrieved is still the old content.
  3. We are hosting the site on Netlify, but did a cache clearing on next publish, still not working.
  4. We use Cloudflare, cleared cache there as well, still not getting up-to-date data
  5. Tried removing the slice and adding a new one. Then publishing again, nothing gets updated.
  6. We have previews setup and we can see the updated content in the preview, but not after publishing.
  7. Next step is throwing this page in the trash and creating a new one, but if there is a way to see if this is an issue on your end first it may be beneficial.
1 Like

Hello team, welcome to the community!

I'm assuming you're using the gatsby-source-prismic plugin. Is this correct?

Thank you for listing all the extra details; this helps us discard where the problem isn't.
The last thing that I think could be missing is to add the updated JSON schema of the Custom type to the local JSON files.

Whenever you create or change a Custom type, like adding or renaming a field, you need to re-do his process manually.

Here's the doc that explains how to do it.

I have not made any changes or additions to the custom type. The issue started when I was changing content on one of the slices that was already there (a simple text update) and I received an error asking to "retry publishing". Ever since then no matter what content I try and change on either the main section of this page or to a slice that already exists on this page, it will not update.

That is when I attempted the steps above because the API is still sending out the old content... even though Prismic UI shows it is updated and the preview shows it updated.

Ok I see, could you please share with me the URL of your repository and the approximate time when you last tried to save this document so we can check the logs?


This was 4 days ago. I had 5 publishes for the "privacy_main_page" type, the first of which was the one that said it failed. Can't recall what time of day it was though.

Ok, I'll send this over to the team

Thank you!

I have not heard anything back regarding this. Have you heard anything or have any type of response yet?

Hello @dev15, I just checked, and we aren't able to reproduce the issue on our side yet; since the last time we talked, there have been several changes/publications, and we cannot pinpoint where the issue is coming from. What would help us a lot to find the problem would be that you write back to us the next time you find the error to find the logs of a specific time of change or publication date.

This issue has been closed due to inactivity. Flag to reopen.

I just wanted to let you guys know that in the interest of our site needing to be updated I archived and deleted that original "Privacy" page type altogether and re-created a new one. I then re-added the same content and published so that we could get this updated stuff onto the site. I'm not sure what was going on and why the API would not give us the updated content, but doing this has allowed us to update it.

Hey Team,

I'm glad you figured this out and were able to advance with your project.

This was definitely a strange one. If you this or anything similar in the future, don't be afraid to reach out.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.