Updating Slice Issue

Hello,

I am trying to push my Slice to my Prismic repo to use with my slice library, but I am running into an issue. I am using the Slice Library Starter for NextJS (https://github.com/prismicio-community/slice-library-starter-next). I have a screen shot of my console, and just not sure what the fix is.

Here is the link to my repo: https://github.com/franklyg/francesco-slices

I have referenced other forums to update the slicemachine ui. I have logged in and out, restarted my dev server, but no dice :frowning:

Thank you for you help/advice in advance,

1 Like

I've been having the exact same issue for the last week or so.

I dug through the node_modules/slice-machine-ui/server/api/push.js and commented out that line and was able to see the response [slice-machine] { status: 403, fake: true, err: 'You are not connected to Prismic' }. Digging a little further I was commenting out some code and following the log of events in lib/client/index.js, and when my .prismic credentials were loaded at push time, everything was undefined.

I tried this same setup on a different account and a different computer and was able to replicate the same issue, so at this time I'm at a loss as well.


Development Setup:
Node Version: v12.16.3
Prismic CLI: 3.8.3-beta.0
slice-machine-ui: 0.0.39

I'm also having this same issue. Tried various things to make it work, but no luck.

I followed the steps in this guide that was having similar issues.

Even when I would do the following steps:

  1. Run prismic logout
  2. Run prismic sm --develop
  3. Get prompted to login, and then run the dev server

It seemed that the application was still running the client in fake mode and giving the 403 issue as my previous comment.

Looks like the same issue as reported here: Unable to push slices to prismic in slice-machine

1 Like

Hey @f.gisonni, @tonym, and @oliver1, Sorry for the delayed response. I just wanted to follow up to see if you're still having any issues. If so, we published a troubleshooting guide, here:

If you don't see the solution to your issue there, please let me know!

1 Like

This issue has been closed due to inactivity. Flag to reopen.