Video hosted on Backblaze - URL doesn't support oEmbed spec

I have a video which I have hosted on Backblaze and I want to use it within my Prismic repository. I set this up as an "embed field", but when I pasted the link I got the above error. Will my content work anyway? Should I use a different content type for this video?

Hi Chris,

Thank you for contributing to the Prismic community; I will try to debug this with you.

To do so, can you please provide the URL of the video you are trying to use in oembed field? as well as your repository name (in a private message if necessary).

Looking forward to your reply,
Fares

Hi Fares, sent you a PM. Thanks :slight_smile:

Well it seems that the service that you are using to host this video is not compatible with the implementation that Prismic is using of OEmbed protocol, for that I will create an issue on our tracker.

We will let you know in case of any updates on this,

Best,
Fares

Hi Fares, thanks for your reply and for creating an issue. In the meantime, what would be the best solution for embedding this video? I would prefer to continue using Backblaze for my media storage.

Well, you can use other video hosting services such as youtube, Vimeo, loom, etc...

I'm not really keen on using any of those sites. As a workaround I just stored the video link as a normal link and created the video player by plain html.

Thanks for sharing this workaround, There is already an issue created on our side and we will update you in case of any new activity