Cannot embed an instagram / FB post in Rich text

Hello :slight_smile:

There seems to be an error while trying to embed Instagram or Facebook posts inside a Rich text field. When I set the url of the post in the embed input and press "insert" it keeps loading indefinitely.

There also is the following error in the console :

main.js:451 Uncaught RangeError: No value supplied for attribute type

And while checking the network tab, I realised whenever it tried to get the embed post, I get a 200 response but with the following json object :

{"title":null,"embed":{"provider_name":"Instagram","provider_url":"https://instagram.com","error":{"message":"API access disrupted. Go to the App Dashboard and complete Data Use Checkup.","type":"OAuthException","code":200,"fbtrace_id":"ACE9-ppqYa-_nyIWRIVqfRz"}}}

(might be related to this Contrôle de lʼutilisation des données - App Development - Documentation - Facebook for Developers)

Thank you in advance for your help

1 Like

Just want to add that I'm experiencing this issue as well.

1 Like

Hi Team,

Thanks for pointing this out. I'm looking into this with the devs and I'll get back to you as soon as possible.

Thanks.

I wasn't able to recreate this bug on my side @romain @devon.noeldetilly ,

Please provide me with:

  1. Your repository URL.
  2. The UID of the document where you are seeing this issue.
  3. The link you're trying to embed.

With this I'll be able to recreate this easier and get help from the devs faster.

Thanks.

Hello Phil,

This might have already been resolved :slight_smile:
I just tried it again and I cannot reproduce it anymore on my side neither.

I don't know if @devon.noeldetilly still has this bug.

Thanks for your time

1 Like

OK, great. Thanks for letting us know :slight_smile:

Seems to be working on my side as well now, those JS errors are gone. Thanks @Phil

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.