[custom-types/push] Model not pushed: property "repeatable" in local Model differs from remote source

I decided to change a single type to a repeatable type. However, when I tried to do that I got the following error

[custom-types/push] Model not pushed: property "repeatable" in local Model differs from remote source

I even tried to delete the document from Prismic, but it doesn't work.

At the moment, this is a blocker and I can't make the desired change

1 Like

Hello @kris, thanks for sharing your use case. We don't have a fix for this just now. But I'll inform the team and let you know when we have a solution. Meanwhile, the only workaround would be to use a different ID for the new repeatable Custom Type.

I have run into the exact same issue that @kris describes here. @Pau could you explain to the community whether the ability to delete custom types will be added in future versions of the slice machine?

I've run into this problem quite a lot so far and it just seems really strange that it's not possible to delete a customtype and instead the solution that's offered is to create a whole new customtype with a new ID, which let's be honest, in larger projects is not a feasible solution.

Thanks!

Hello @taylorollie1 thanks for reaching out about this.Yes, we’re currently developing features for Custom Type deletion. We have an open survey to help us icollect data and inform our decision in the design phase.

This survey contains only 4 questions and will take 90 seconds to answer.

Your feedback is greatly appreciated!