"Doesn't Exist" Error from Integration Fields Custom API

My application has an endpoint created by the following plugin: GitHub - elgentos/magento2-prismicio: Magento 2 Prismic integration The endpoint (and pages) work fine when visited directly, I have it openly accessible - there is no password or other security on the URL though other URLs on the domain are protected.

However, when I try and sync the items in the Integration Fields admin, I'm getting the error "ENDPOINT URL doesn't exist".

The feature was only recently enabled on the account. I have tried disabling all protection on other URLs of the site but it still didn't work so I have re-enabled it.

Can anyone advise?

Hi there,

Can you please tell us what do you mean by "work fine when visited directly" and from where?
Have you tried to access your endpoint using Curl or some tools such as Postman?

If you have done so and it works using those tools, then we need to try to reproduce the issue together.

To do so I will need your Prismic repository name, the endpoint you are trying to call as well as the request that you are doing.

Looking forward to your reply,

This issue has been closed due to inactivity. Flag to reopen.