Extended quota for record size

We're getting the following response from the API for one of our documents. Do we need our quota extended? I thought the maximum document size is 250kb?

"Record at the position 0 objectID=XXXXXXXXXXXXXXXX is too big size=21168 bytes. Contact us if you need an extended quota"

Hi Suleman,

Welcome to the Prismic community,

Can you please provide us with the repository name as well as a link to the concerned document (in a private message if necessary)?

Looking forward to your reply,

Hi Fares,

I've sent you a private message.



1 Like

Thanks for your reply,
I have submitted that information.


I've checked with our DevOps team, and we don't think that this massage comes from Prismic, but to be sure, can you please provide us with the query you are doing to get this message?

We tried to query the API by this document.id, and it seems to work fine!

Looking forward to your reply,

We're just simply querying for the document by ID. We reduced the size of that particular document which seems to have alleviated the problem. I'm monitoring our documents to see if we get the problem again. I will let you know. Thanks!

Thanks for letting us know, can you please let us know if you have this issue again?

And a side question, I did a research online and I found that this issue can be related to Netlify, do you use this hosting platform?

Sure, I'll let you know if I see this again.

Nope, we do not use Netlify.

1 Like

May be worth switching to the GraphQL API so you can return only the fields you need?

1 Like

This issue has been closed due to inactivity. Flag to reopen.