Fulltext search issues

I am trying to implement fulltext with prismic api & getting very strange behaviours. Appreciate some help to understand the feature better.

Examples :

  1. Tried to search document keyword with "Hampta" -> Got 10 records = NOT OK = Here search result not matching with expected result and i couldn't see text matching with my search criteria "Hampta" anywhere in document. What all are the field considered for search with fulltext ?
  2. Tried to search document keyword with "hampta" -> Got 0 records - NOT OK = Search is case sensitive? It's really hard to ask end customer to search on a.specific format). Any workaround for this ?
  3. Planning to search with full text custom field contains array value & getting 400 from API. Is it allowed to search only the flat fields for custom field ?

Hi @todeepthydon,

Thanks for reaching out; it would help if you could give us some examples of your queries.

Also, it will be equally helpful to have your repository name and a link to the document with the field in question (you can share that in a private message if necessary).

Looking forward to your reply,

I sent you a private message. PLease check and let me know incase anything else is required.

1 Like

This issue has been handled privately, and turns out that it is related to a limitation for the Fulltext search that only works with full word matches, and a feature request has been created; using a external search engine such as Algolia can solve this issue until Prismic improvements