GeoPoint editing issues - Map is Blank

Howdy Prismic team,

I'm having an issue editing content on my Prismic instance using the GeoPoint field.
Punching a Google Map link into the text field does correctly convert it to latitude/longitude points which my frontend app is able to use. However on the content entry side, the map is rendering blank - just a white box with Zoom In/Zoom Out slider and "Leaflet" text in the lower left. I've tested it in both Firefox 79.0 and Chrome 84.0 on OSX, and have disabled any adblockers or similar plugins.

What's interesting is that I can blindly click and drag the blank map to a new point and then back out of editing the document, and the [ Save to a new version / Discard my changes ] dialogue modal appears to correctly show a mini view of the streets for the location update preview.

Here are some interesting messages I found in the console output when loading a document containing a GeoPoint in the Prismic editing UI that may be of some help:

GET https://a.tiles.mapbox.com/v4/sre.gbd38ga6/1/1/1@2x.png?access_token=pk.eyJ1Ij[...redacted] [HTTP/1.1 410 Gone 250ms]

Uncaught TypeError: t is undefined
p main.js:490
g main.js:490
fireEvent leaflet-src.js:461
bind leaflet-src.js:54
a main.js:329

Thanks!
Mel W
Developer

1 Like

Hello, welcome to the Community forum!

Thank you very much for informing us about this issue. I've made the team aware about this. I'll keep you updated about any news in this same thread.

Could you tell me if the Google map that you paste into the field saves the correct address ??

Hi Paulina,

Yes, it appears to pull the correct latitude/longitude out of a pasted Google Map link, and I can even see that coordinates value changing if I blindly drag around the blank map.

The address works in our custom frontend implementation, but our content editors are not able to see the streets and map pin in the GeoPoint map preview to double check the address while creating/editing content.

1 Like

Paulina, I have this same issue. My map is blank when i am entering a resource.
Also, not all published resources are showing!

1 Like

Hello,

We are experiencing this issue as well:

  • Map does not render (only a white box)
  • Pasting in a google maps link does not find the correct latitude and longitude
  • Moving the map when scrolling down the page is very annoying. We suggest the "hold command/control while scrolling to zoom" functionality.
1 Like

Hey everyone, thank you so much for your comments, we're currently reviewing this issue. And we're gathering more information.

@spayne Could you tell me which resources aren't showing, is this just about the GeoPoint field or something else?

@dev8 Can you give me an example (a screenshot would be super useful or a screen recording) of how the save lat/long value isn't the correct one??

Thank you very much,

Good morning,

When I go to the spot where you put the coordinates, the map is not there at all. Before or after adding the coordinates.

I could see it two weeks ago….

image002.jpg

1 Like

Hi,

I am no longer able to re-create the error with google maps links! Hopefully it sorted itself out.

However, I am still seeing the same error as @spayne.

Thank you!

1 Like

I just had a client point out to me that the map in Prismic is not working, that's how I got on this thread.
It looks like part of the issue is that the map style is no longer supported by your map provider.
{
message: "Classic styles are no longer supported; see https://blog.mapbox.com/deprecating-studio-classic-styles-d8892ac38cb4 for more information"
}
Is there any indication when this issue will be resolved ?

Greetings Arjen

Hello @supersites, thank you for joining the conversation and welcome to the forum!

For the moment we don't have a rough ETA on when this is going to be solved. But I'll keep everyone updated about this in this same thread.

Thank you very much for your patience.

Good morning Paulina,

I still do not see the map in Prismic when I am entering a new resource.

When can I expect this to be fixed?

My app is map dependent and this is a crucial!!!

Hello @spayne, we totally understand that this is, indeed, a bad user experience when using the writing room. We're trying to prioritise this as much as we can. When I get news about this I'll come back to this thread to inform everyone.

Thanks a lot

+1 very annoying issue when will this be resolved?

Hello everyone, and also, welcome to the forum @flexer !!

Just wanted to let everyone know that this is now a High priority task and we'll solve this as soon as we can. I'll keep everyone updated in this same thread when the fix is ready.

Thank you all for your comprehension!

I have the same issue, My app is map also dependent and this is a crucial!!!

Need a solutions !!! Please!

1 Like

Hey Daniel, this fix is currently being tested before it's release. As soon as it's rolled out I'll inform everyone in this same thread.

Thanks