How can I change the owner of locked repo

Hello,

We cannot pay because the repository owner is not in the company and we cannot transfer the repo because it's unpaid...

Do you have a solution ?

Best regards

Hi @dimitri.pilarski,

Thanks for posting this question, and welcome to the Prismic community.

You can transfer an unpaid repository. See the docs, here:

Let me know if that doesn't address your situation.

Sam

Hello,

I tried what is suggested in your link but I got a 403 as you can see on the following screenshot

Hey @dimitri.pilarski,

I'll check with the billing team and get back to you.

Sam

Hi Dimitri,

Your repository is now unlocked, you should be able to make the change.
Let me know how it goes.

Hello,

Thanks for the unlock, I just tried to transfer ownership but it seems I don't have required permissions even as Administrator.
What is the minimum role needed to do this ?

Could you transfer the ownership on your side because as said, the repository owner is not in the company.

Don't hesitate if you need more information

Hey @dimitri.pilarski, I'll look into this and get back to you. I'm offline tomorrow, but I'll respond on Wednesday.

Hi,

Do you have more information ?

@dimitri.pilarski I don't have any info yet, but I'll follow up with the billing team and get back to your tomorrow.

Hi @dimitri.pilarski,

Can you send me a DM to confirm:

  • the last 4 digits of the credit card used for payments on the repo
  • the name on the credit card
  • the name of the user to transfer ownership to (as it appears in Prismic)

Thanks,
Sam

Hi @samlittlefair

Unfortunately we don't have these information either (except the name of the user to transfer the ownership)