Integration Fields error in Slice Machine


Trying to get the Shopify integration to work with slice machine. Adding the integration works fine in the Dashboard i.e. it gets a green check mark and gets "synced". But it is not shown as a field. But if I switch to Legacy Builder it is shown.

But since I want to use slice machine I tried to get it to work by adding the integration as a IntegrationFields type in one of my customtypes using the following format:

"Products": {
  "type": "IntegrationFields",
  "config": {
      "catalog": "nosco--products",
      "label": "Products",
      "placeholder": ""

And then running npm run slicemachine gives me the following error for the added IntegrationFields "Field type "IntegrationFields" not supported"

Please help me out. What am I missing?


1 Like

I already tried the solution with the index.json for my customtypes. So index.json for customtypes does not work? I need to do it in model.json for my slice?

I have tried models.json as well without success. I've also requested and got the Integrations Fields feature activated for our repository: "We have successfully activated Integration Fields for the repository. You can find more information on Integration Fields".

Not sure what more I should try. Should I stop using slice machine and use legacy instead since that works?

Hi Daniel,

I moved your messages here because I saw you had tried the suggested workaround to use Integration Field with Slice Machine by editing the model.json file as detailed here:

Can you show me the full model.json and index.js file for the Slice that you're trying to create?

As much code, context and screenshots as you can provide me will allow me to help you :slight_smile:

Unfortunately, i've got the same issue..

Got the 'synced' checkmark in dashboard but the integration field won't work. Did the changes in my model.json, build the slice machine, pushed to prismic but then the only thing I see in the slice machine is "Field type "IntegrationFields" not supported". Also in my documents the field is not visible.

Working with; "slice-machine-ui": "^1.23.1"

Thanks in advance!

Hi John,

'Integration fields' isn't available in the new page builder, so this is unrelated to Slice Machine, I guess.

I've re-enabled the legacy builder for you so you can move forward.