Issues with "prismic theme" command using CLI

Hi! I am trying to use my Prismic theme to start a new project, but keep running into errors using the CLI.

My preferred way of doing this is using a ZIP file since I don't want the code to be public.

These are the commands I have tried so far:

prismic theme
prismic theme ./
prismic theme --theme-url
prismic theme --theme-url --conf --ignore-conf

Each of these commands return the following error:

An error occured while running Theme#initializing
    TypeError: Invalid URL

I have double- and triple checked that the ZIP file is in the correct place and have the right name.

I have also tried using an actual URL (example: "") for the ZIP file, but then I get stuck on this error message:

An error occured while running Theme#initializing
    AssertionError: Trying to copy from a source that does not exist: /tmp/tmp-2996-1C69JxcFxPBY/undefined-p-template-main

As a last resort, I tried to temporarily make the GitHub repository public in order to use the theme, but then I receive a very long error message when the CLI is attempting to create a new Prismic project. I have uploaded the file here: (14.1 KB)

Please help me figure out what I am doing wrong here, since it feels like I have tried every available command and approach in order to get this to work.

Hello @perriekkola

Welcome to the prismic community, and thanks for reaching out to us.

If your GitHub repo is public, then the theme command should look like this:

prismic theme --theme-url <github_repository_url> --conf --ignore-conf

Replace the github_repository_url with the link to the project in Github. For example, for our nodejs blog project the github repo URL is: command is: GitHub - prismicio/nodejs-blog

If your GitHub repo is private, you need to download the private repo as a zip file and pass the path to the zip file to the theme command --theme-url=../path/to/my/

Give this a try, and let me know.


Hi Priyanka and thanks for the response!

Still receiving the same error code for the zipped version:

prismic theme --theme-url=./ --conf --ignore-conf
? Name your prismic repository:
project folder [p-t-test]:
✖ An error occured while running Theme#initializing
    TypeError: Invalid URL

When trying the public GitHub repository I receive the same error as in the uploaded file in my original post.

Any idea to why these commands are failing?
I have double checked locations, URL:s and settings in GitHub. The zip would be the preferred way of doing this, but I have a hard time understanding the error I get.

Hello @perriekkola

I am not sure why you are getting the error. I can debug it if you share your project source code with me so I can push it to my Github and try to create a theme command. You can send me a private message.


Thanks Priyanka! I have sent you a DM with the files.