Linkedin open graph image urls not being picked up

Hi for my website, for some reason linkedin is not picking up the og:image meta tags (it picks up the other meta tags)

facebook, twitter etc. don’t have the same problem

eg. using Linkedin post inspector:

however with it seems like the website is configured correctly ( as input)

could it be that the prismic image CDN is being blocked by linkedin?

Maybe something here will help?

Or it might be because the supplied URL is a 404.

Sorry it should be

I already viewed many issues that were made over the years and tried some of the ‘strategies’ - one thing I can’t get my head around is that Facebook debugger does not have the same problem, and that Linkedin was working fine until recently despite no code changes.

I would like to clarify that even though I am using react-helmet, I am using the plugin that makes sure the meta tags are part of the static build.

It might be linkedin’s fault, since other people have the issue too.

We’ve been experiencing the same issue on our blog.

  • The only thing I could find that changed anything was using jpg images instead of png.
  • But even then, it sometimes works and sometimes doesn’t and I have no clue why.
1 Like

I've been having this issue too, different tech stack (.net core). I found that URLs with spaces have been a problem, I've advised the content editors to ensure images are all lowercase and hyphenated and that seems to have solved it.

I don't think this is prismic's fault, but I would love to have the ability to automatically enforce a naming convention for images, or at the very least to allow the image to be renamed.


I think this is a good idea and a solid use case so I've tagged this as a feature request in our tracker.

If/when the team needs any more information they'll contact you here.


1 Like

Reopening as @rami.daghlawi has provided a workaround :slight_smile:

Thanks Rami.

This issue has been closed due to inactivity. Flag to reopen.