New Editor - Unable to save due to archived doc with the same slug

Hello there,

We are attempting to save a document that uses the same slug as an archived document but we keep having an error warning.

This works correctly when we use the legacy editor, can you please provide any insight?

Thank you

Hi Rita,

Welcome to the community!

This is the behaviour in the legacy editor as well. You'll need to delete the archived document.

Thanks.

Hi @Phil ,

Thanks for your quick reply, however, we have always had those archived documents and works on the legacy editor.

As per my previous post the New Editor shows the error and doesn't let me save any changes


Legacy Editor, you can see that we can save any changes

OK, thanks for following up. These screenshots really help. I'll check with the team and get back to you.

OK, so there's a discrepancy between the functionality of the builders. I'm confirming with the team which is correct and the next step here. Either way, I know the team is working on improved UID management, so hopefully, soon, this won't be something you'll have to worry about.

Hi!

We've just been switched over to the new Page Editor today and have found we can't make changes to one of our main pages due to the duplicate slug issue. We have deleted the archived document that contained the same slug but we still cannot save our newer page.

The only way to update the page seems to be to switch back to the legacy editor temporarily.

Is there any update on whether this issue is being fixed?

The team is still discussing how to handle this in the new builder. We'll get back to you on this soon.